
Check Issue File Formatter
Using the Positive Pay File Formatter to upload Positive Pay files
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Introduction 
Welcome to Check Issue File Formatter, a Positive Pay file creation and transmittal software package.

In order to participate in the BMO Harris anti-fraud Positive Pay service, you need to regularly send the bank a list of the checks you 
issue from your checking account. This program enables you to create the check issue files in the format required for transmission to 
BMO Harris Bank.

Getting Started 
DOWNLOAD THE FILE FORMATTER SETUP FILE 

Open your web browser and go to the following url:  
http://treasurysoftware.com/zserver87504649352491113.html

Click on the link labeled “Click here to download and Install 
Treasury Software 2012 (30MB)” to download the Setup File.

After clicking the link, select to Save the installation file. 

Save the installation file to your “desktop” for easy access.

Download to the file destination,  
in this case the Desktop, and once 
the download is complete, the 
installation file icon will display. 
Double click the icon to install the 
software on your PC.

The InstallShield will appear. 

You will be prompted to Accept the terms of the license 
agreement before you can continue. 
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Complete the InstallShield Wizard 
accepting the default settings until 
complete. The Treasury Software icon will 
be saved on your Desktop 

REQUEST LICENSE CODES 

This initial session will enable you to download the file format 
software to create your initial check issue file that you will 
send to the bank but you will not be allowed to use the 
software after an initial 7 day trial period. In order to use the 
software to format your check issue file on an ongoing basis, 
you will need to submit a request for license codes from the 
following web page: 
http://treasurysoftware.com/zserver87514649352491113.aspx 

To request a License Code to continue using the software past 
the 7 day trial period, complete the information on the form 
and select the Bank Contact. Once you submit the form, an 
email will be sent to the 
designated Bank Contact 
for approval. The bank 
contact approves the 
license request and will 
email you the permanent 
license code required for 
subsequent use. . 

When the license code 
is emailed to you, access 
the software and select 
File > Enter License 
Codes. 

The License Code entry 
box will appear. Enter the 
License ID and password, and click the Register “key.” You 
are now a licensed user . Select “Close.” 
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INITIAL SOFTWARE USE 

Follow the steps below to initiate the Positive Pay software. 

1.	 Click the Windows Start button.

2.	 Select Programs or All Programs > Treasury Software.

3.	 Click the Treasury Software icon. The Welcome New 
Users page will load.

4.	 Select the Bank Positive Pay option.

The Welcome New Users page will continue to display until 
the software is licensed. After licensing the software, the 
program will load to the home page.

ENTER BANK EXPRESS SETUP CODE 

1.	 On the Bank Positive Pay home page, use the main menu 
and select File > Options > General. The Options window 
will appear.

2.	 Select the Bank Code tab.

3.	 Enter in the Bank Express Setup Code in the Bank Code field.

•	 Type 875 if you are sending positive pay information 
only and not  payee information (the “Bank Name” BMO 
Harris Bank” will populate).

•	 Type 876 if you are sending Payee information for Payee 
Positive Pay (the “Bank Name” BMO Harris Bank” will 
populate).

4.	 Click the Update Bank Information button.  

5.	 Click OK on the “Update successful” message box. This 
indicates the program has been updated to use the BMO 
Harris Positive Pay format.

Notice that the Bank Name field text changed from “Treasury 
Software” to “BMO Harris Bank” after entering Bank codes 875 
or 876. This text change means the Express Code has been 
entered successfully

6.	 Click Close.

CREATE AN ACCOUNT

This process will create a check issue file account.

1.	 Click File > New Account to start the Account Creation 
Process. The Account Wizard window opens.

2.	 Select Create an account + Add it to your Catalog.

3.	 Click the Next button to continue.

4.	 Enter an Account Name.

5.	 Select “Positive Pay.” 
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6.	 Click the Next button to continue

7.	 Enter the account number in the Your Bank Account 
Number field.

8.	 Enter the three digit bank number 028 in the Your Bank 
Number field.

9.	 Click the Next button to continue.

10.	Click the Finish button on the Congratulations screen. 

Import Check File Data 
Using the Check Register Import Wizard: follow this process to 
import check issuance transaction data to create a check issue 
file for upload to the bank. 

1.	 Start the Check Register Import Wizard by clicking 
the Import Check Register icon in the center of the 
homepage or by selecting Import > Check Register off the 
top menu.
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2.	 To import check data, you can browse and click “Select 
File” under the Folder icon. 

To select a file to import, select your file and click Open. 
Common file software types are Excel® (.xls), Access® 
(.mdb) , Comma Delimited (.csv or .txt), tab delimited (.txt) 
and text (.txt).

Notice the path and file name have now been populated 
in the General Ledger Import Wizard window. Click Next to 
continue. 

The “Select a worksheet or range” screen is designed to 
allow the user to select the appropriate worksheet from 
an Excel® file that contains the data to be imported. If you 
can see your data from the Excel® file in the grid, simply 
click the Next button. 

If you choose source data from a Microsoft® Excel® file,  
data can be copied directly from the Excel® spreadsheet  
and pasted directly to the software by selecting the  
Paste button.
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The screen below shows the check issue data pasted from 
an Excel® Spreadsheet

Click the Next button. 

3.	 After importing the check data, the General Ledger 
Column Mapping screen allows the user to identify what 
information is contained in each column on the import file. 
Simply highlight a column, and then select the appropriate 
column mapping from the drop down for the data. 

4.	 Mapping Rules

•	 Debits: when importing debits as positive transactions, 
map the column for the amounts as Amount_ Reverse_
Sign. This ensures that the debits will be viewed as 
balance decreasing transactions. 

•	 Account numbers are not required in the input data, and 
do not need to be mapped.

•	 Action indicator: (4th column or field mapped) identify 
void or deleted items. The action indicator should be 
included in the source data that is loaded to the File 
Formatter software within a separate column: 
–	 Register Adds: Default, no action necessary. 
–	 Register Deletes: Action indicator of “D”. 
–	 Void Adds: Opposite +/- of default items. 
–	 Void Deletes: Opposite +/- of default items and action 

indicator of “D”. 
•	 You need to map the columns only one time (or 

whenever you change the format of the input data). 
5.	 The section above the column field numbers (Field 1,  

Field 2, Field 3, etc.) switches from red to green ( as 
shown in the screen below) and lists the selected 
mapping. Repeat for all required columns. 

6.	 Be sure to map the required columns: Date, Check 
Number, Amount/Amount Reverse Sign, Action Indicator.
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	 Payee names should be mapped as Payee (Description) for 
those who are creating check issue files with payee name 
data.

IMPORTABLE RECORDS 

1.	 The “Review records” screen displays a list of the 
importable rows and invalid rows. To review the list of 
Importable records, click on the + (plus sign). The records 
listing will expand and display a list of importable checks, 
and the basic check information.

	 The invalid row is the row of column headings. The File 
Formatter automatically marks header rows, footer rows, 
summation lines, and blank lines as invalid. For each 
row that is invalid, a check mark will be placed in the 
appropriate column indicating why the row was invalid. In 
the screenshot below, both the Amount and Date columns 
contained text instead of an amount and date value, 
making the row invalid.

2.	 Once you have verified the importable information is 
accurate, click the Next button. If you wish to cancel  
the import process and try again, simply click the  
Cancel button. 

3.	 Click Finish to complete the General Ledger Import Wizard.
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Positive Pay File 
TRANSMITTING A POSITIVE PAY FILE TO THE BANK

1.	 Select “Create File” to create the check issue file and 
begin upload process

2.	 Click the Create Issue File button to create the Positive 
Pay file. 

	 The created file will be saved as noted in the third 
paragraph displayed on the screen above.

•	 The first paragraph on the screen indicates how many 
records will be included in the transmission file (in this 
example, there are 15 records). 

•	 The second paragraph indicates the selected 
transmission method. (This will always be Web Upload.)

•	 The final paragraph displays where the transmission 
file will be saved. The default location for the file is the 
C:\Program Files\Treasury Software\Treasury Desktop\
To Bank directory. The default file name is the name of 
the account, followed by an underscore and the word 
‘transmit’. The file will always have a .TXT file extension.

3.	 The program provides you the option to view the recently 
created file. Select the Yes button if you want to view and 
verify the file format. 

4.	 The Check Issue File created is displayed below.

5.	 After file creation a web browser will then open to the 
BMO Harris Online Banking for Business (OLBB)  
https://www21.bmo.com/ login screen. 
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6.	 After you login to Online Banking for Business, select the 
Account Information tab and navigate to File Transfer 
Facility (FTF). 

7.	 Click Send File to initiate the file upload process.

•	 Select the appropriate Product and Document type from 
the dropdown menu

•	 Browse to attach your file
•	 Click Send File to upload your file. 

8.	 To view a history of sent and received files, go to Account 
Information tab > File Transfer Facility > File History.

Additional Support 
If you have questions regarding the check file creation and 
formatting process call 1.866.226.5732 or access online help at 
http://www.treasurysoftware.com/contact.asp

If you have questions on how to upload your file via the FTF 
module of BMO Harris Online Banking for Business, call the 
Client Services Help Desk at 1.866.867.2173.
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Frequently Asked Questions 
Do I use Amount or Amount Reverse sign?
Amount is used when the records on the file are issued checks, 
and the amount on the import file is listed as a negative amount. 
Amount_Reverse_Sign is used when the records on the file are 
issued checks, and the amount on the import file is a positive 
amount. The File Formatter requires Issued Checks to have a 
negative amount, and Void Checks to have a positive amount. 

I entered the wrong Bank account number and/or Bank 
number. How do I fix this? 
Click File > Options > General. Select the Resume Startup tab 
and click the Resume button. This will re-enter the Account 
Creation wizard and bring you to the page where the Account 
Number and Bank Number are entered. Correct the entries as 
needed, click Next, and then click Finish to save the changes. 

How do I change where the Issue File is saved? 
File > Options > Transmit to Bank. Select the Local File tab, and 
modify the Transmission file location textbox. The Transmission 
File Location must include both a file name and extension (.TXT).

How do I delete a record?
Select Reports, and pick the All Records Report from the Drop 
Down box. 
Select a 
record in the 
grid, and click 
the Red X on 
the toolbar.

How can I delete an entire import? 
Select Reports, and select the Import Logs Report. Highlight the 
import you wish to delete and click the Red X on the toolbar. 
Deleting an import will remove all records from that import file 
from the File Formatter database.

When Importing an Excel® file, my dates convert from  
MM/DD/YY to numbers. How do I avoid this? 
Close the Excel® file when you are importing it into the File 
Formatter. When the Excel® file is open during the import 
process, Excel® converts the dates to Julian format, which will 
be rejected by the File Formatter for an “Invalid Date.” 

Can I manually add a record without importing?
Yes. Click Edit > Add Record and enter in the check information 
on the form. When finished, click OK. 

I need to resend a transaction to the bank, how do I do this?
Select Reports, and select the All Records Report. Highlight 
the record you need to resend and click the “Mark as 
Untransmitted” button. The record will be marked as 
Untransmitted and be included on the next issue file that  
is created. 

How do I enter my license codes? 
Click File > Enter License Codes. Enter in the License ID and 
License Password and click the Register button. If prompted 
to complete the Authentication process, please follow the 
instructions provided on the screen.

Can I also select the ACH Universal or Bank Reconciliation 
option to format a check file to transmit to BMO Harris Bank?
No. The 
Bank 
Positive Pay 
file option 
is the only 
option for 
selection by 
BMO Harris 
Bank clients.

Microsoft®, Excel® and Access® are registered trademarks of Microsoft Corporation in the 
United States and/or other countries. 
Banking deposit and loan products and services are provided by BMO Harris Bank N.A. 
and are subject to bank and credit approval. BMO HarrisSM and BMO Harris BankSM are 
trade names used by BMO Harris Bank N.A. Member FDIC.


